<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">

<head>
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8"/> 
  
   <meta name="Robots" content="index,follow" />  
  
  
  <!-- autoextremist -->

  <link rel="shortcut icon" href="/favicon.ico" type="image/x-icon" />

  <link id="primaryStylesheet" rel="stylesheet" type="text/css" href="/display/common.css?styleId=1814361&amp;RK=1359510686127&amp;CE=75"/>
  
  <link id="slideShowStylesheet" rel="stylesheet" type="text/css" href="/universal/styles/squarespace-gallery-slideshow.css?CE=75"/>
  
  
    <link rel="alternate" type="application/atom+xml" title="ATOM" href="http://www.autoextremist.com/current/atom.xml" />
  
    <link rel="alternate" type="application/rss+xml" title="RSS" href="http://www.autoextremist.com/current/rss.xml" />
  
    <link rel="alternate" type="application/rdf+xml" title="RDF" href="http://www.autoextremist.com/current/rdf.xml" />
  
  
  <!-- Google Web Fonts -->
  <script type="text/javascript">
    	WebFontConfig = {"google": {"families": ["Josefin Sans:400"]}};
  
   
    (function() {
      var wf = document.createElement('script');
      wf.src = ('https:' == document.location.protocol ? 'https' : 'http') +
          '://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';
      wf.type = 'text/javascript';
      wf.async = 'true';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(wf, s);
    })();
  </script>

  <script type="text/javascript" src="/universal/yui/yahoo-dom-event/yahoo-dom-event.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/connection/connection_core-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/json/json-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/animation/animation-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/selector/selector.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/element/element.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/global.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/lightbox.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/api.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/base64.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/census.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/yui2-yui3-bridge.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/squarespace-gallery-slideshow.js?CE=75"></script>


  <script type="text/javascript">
  // <![CDATA[

    Squarespace.Constants.SS_AUTHKEY = encodeURIComponent("");
    Squarespace.Constants.WEBSITE_TITLE =  "Autoextremist.com"; 
    
     Squarespace.Constants.CURRENT_MODULE_ID = "1858948"; 
    
    
    
    Squarespace.Constants.ADMINISTRATION_UI =  false; 
    
    
     Squarespace.Constants.OBJECT_PERMALINK = "http://www.autoextremist.com/current/2017/8/14/the-overhyped-the-overblown-and-the-overrated.html"; 
    Squarespace.Constants.CORE_APPLICATION_DOMAIN = "squarespace.com";
    Squarespace.Constants.CORE_V6_APPLICATION_DOMAIN = "squarespace.com";
    Squarespace.Constants.V5_FRONTSITE = "http://five.squarespace.com";
    Squarespace.Constants.WEBSITE_ID = "192288";

    

    

    

  // ]]>
  </script>

      <title>THE OVERHYPED. THE OVERBLOWN. AND THE&nbsp;OVERRATED. - Rants - Autoextremist.com ~ the bare-knuckled, unvarnished, high octane truth...</title>
    <meta property="og:title" content="THE OVERHYPED. THE OVERBLOWN. AND THE&nbsp;OVERRATED. - Rants - Autoextremist.com ~ the bare-knuckled, unvarnished, high octane truth..." /> 
  

      <meta property="og:description" content=" Editor's Note: So, the Autoextremist says he's tired (exhausted is more like it), and there is cle..." />
  

  

  <!-- End Heading -->

  <META NAME="Keywords" CONTENT="automotive news, automotive commentary, auto racing, automobile industry, auto industry,Ford, Chevrolet, GM, Toyota, Buick, Nissan, Volkswagen, Porsche, Audi, Honda, Pontiac, Chrylser, Damlier, Mercedes"/>
<META NAME="Author" CONTENT="johnt@c2group.com"/>


  <script type="text/javascript" src="/universal/scripts/cookie-min.js"></script>
  <script type="text/javascript" src="/universal/scripts/eu-cookie-policy.js"></script>

</head>

<body  id="modulePage1858948"   class="objectId35955114"  >

  <script type="text/javascript">
  YAHOO.util.Event.onDOMReady(function() {
    if (document.location.href.indexOf("SSLogoutOk=true") != -1) {
      new Squarespace.FixedPositionTip("Logout Successful", "You have been successfully logged out.", { xMargin: 15, yMargin: 15, icon: "/universal/images/helptip-info.png", orientation: "upper-right", viewportFixed: true, autoHide: 1800 }).show();
    }
  });
</script>

    

  <script type="text/javascript">
    YAHOO.util.Event.onDOMReady(function() { new Squarespace.Census.hit(); } );
  </script>

  <script type="text/javascript">
    YAHOO.util.Event.addListener(document, "keyup", function (e) { if (!e) { e = event; } if (e.keyCode == 27) { document.location.href = "/login/?returnUrl=%2Fcurrent%2F2017%2F8%2F14%2Fthe-overhyped-the-overblown-and-the-overrated.html"; } });
  </script>




  

  <div id="canvasWrapper"><div id="canvas">
  
  

  <div id="pageHeaderWrapper"><div id="pageHeader">

      <div id="navigationTop"><div id="navigationTop-sectionContent981974" class="horizontalNavigationBar"><ul class="content-navigation">
    
  <li class="module active-module  " id="navigationTop-moduleContentWrapper1858948">

    <div id="navigationTop-moduleContent1858948">

              <a id="navigationTop-moduleLink1858948" class=" " href="/" ><span>Rants</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper1882163">

    <div id="navigationTop-moduleContent1882163">

              <a id="navigationTop-moduleLink1882163" class=" " href="/on-the-table1/" ><span>On The Table</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper1882168">

    <div id="navigationTop-moduleContent1882168">

              <a id="navigationTop-moduleLink1882168" class=" " href="/fumes1/" ><span>Fumes</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper1882165">

    <div id="navigationTop-moduleContent1882165">

              <a id="navigationTop-moduleLink1882165" class=" " href="/the-line1/" ><span>The Line</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper1882171">

    <div id="navigationTop-moduleContent1882171">

              <a id="navigationTop-moduleLink1882171" class=" " href="/road-kill1/" ><span>A Bud&#39;s Life</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper1882448">

    <div id="navigationTop-moduleContent1882448">

              <a id="navigationTop-moduleLink1882448" class=" " href="/autoextremist-image-gallery/" ><span>Image Gallery</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper1882196">

    <div id="navigationTop-moduleContent1882196">

              <a id="navigationTop-moduleLink1882196" class=" " href="/emails-of-the-week1/" ><span>Reader Mail</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper1858949">

    <div id="navigationTop-moduleContent1858949">

              <a id="navigationTop-moduleLink1858949" class=" " href="/about-us/" ><span>About AE</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper1859799">

    <div id="navigationTop-moduleContent1859799">

              <a id="navigationTop-moduleLink1859799" class=" " href="/search-autoextremist/" ><span>Search AE</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper1859817">

    <div id="navigationTop-moduleContent1859817">

              <a id="navigationTop-moduleLink1859817" class=" " href="/contact-ae/" ><span>Contact AE</span></a>
      

      

    </div>

  </li>


  </ul><br class="clearer"/></div></div>

    
        
      
  
      <div id="bannerAreaWrapper"><div id="bannerArea">

        
        <div id="bannerWrapper">
          <a href="http://www.autoextremist.com/"><img id="banner" src="/storage/autoX_banner.jpg" alt="Autoextremist.com" title="Autoextremist.com"/></a>
        </div>  

      
      
      </div></div>
    
    
    

      <div id="navigationBottom"><div id="navigationBottom-sectionContent981974" class="horizontalNavigationBar"><ul class="content-navigation">
    
  <li class="module active-module  " id="navigationBottom-moduleContentWrapper1858948">

    <div id="navigationBottom-moduleContent1858948">

              <a id="navigationBottom-moduleLink1858948" class=" " href="/" ><span>Rants</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper1882163">

    <div id="navigationBottom-moduleContent1882163">

              <a id="navigationBottom-moduleLink1882163" class=" " href="/on-the-table1/" ><span>On The Table</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper1882168">

    <div id="navigationBottom-moduleContent1882168">

              <a id="navigationBottom-moduleLink1882168" class=" " href="/fumes1/" ><span>Fumes</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper1882165">

    <div id="navigationBottom-moduleContent1882165">

              <a id="navigationBottom-moduleLink1882165" class=" " href="/the-line1/" ><span>The Line</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper1882171">

    <div id="navigationBottom-moduleContent1882171">

              <a id="navigationBottom-moduleLink1882171" class=" " href="/road-kill1/" ><span>A Bud&#39;s Life</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper1882448">

    <div id="navigationBottom-moduleContent1882448">

              <a id="navigationBottom-moduleLink1882448" class=" " href="/autoextremist-image-gallery/" ><span>Image Gallery</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper1882196">

    <div id="navigationBottom-moduleContent1882196">

              <a id="navigationBottom-moduleLink1882196" class=" " href="/emails-of-the-week1/" ><span>Reader Mail</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper1858949">

    <div id="navigationBottom-moduleContent1858949">

              <a id="navigationBottom-moduleLink1858949" class=" " href="/about-us/" ><span>About AE</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper1859799">

    <div id="navigationBottom-moduleContent1859799">

              <a id="navigationBottom-moduleLink1859799" class=" " href="/search-autoextremist/" ><span>Search AE</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper1859817">

    <div id="navigationBottom-moduleContent1859817">

              <a id="navigationBottom-moduleLink1859817" class=" " href="/contact-ae/" ><span>Contact AE</span></a>
      

      

    </div>

  </li>


  </ul><br class="clearer"/></div></div>


  </div></div>
  
  

  

  
  <div id="pageBodyWrapper"><div id="pageBody">
  
  <div id="sidebar1Wrapper" class="verticalNavigationBarWrapper"><div class="iw-vnb1"><div class="iw-vnb2"><div class="iw-vnb3"><div class="iw-vnb4"><div id="sidebar1" class="verticalNavigationBar">

  

    <div id="sectionContent981973" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper1859818" class="widget-wrapper  widget-type-page"><div id="moduleContent1859818">





  <hr />
  <div align="center" style="text-align: center;">No. 910</div>
  <div align="center" style="text-align: center;">August 16, 2017</div>
  <div align="center" style="text-align: center;"><span style="font-family: Arial;"><span class="ssNonEditable full-image-block">&nbsp;</span></span></div>
  <hr />
</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent8144685" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper19455702" class="widget-wrapper  widget-type-page"><div id="moduleContent19455702">





  <h3>About The Autoextremist</h3>
  <p><span class="thumbnail-image-block ssNonEditable"><span><a href="javascript:showFullImage('/display/ShowImage?imageUrl=%2Fstorage%2Fpmd15-26.jpg%3F__SQUARESPACE_CACHEVERSION%3D1432995723468',1024,991);"><img src="/storage/thumbnails/1858946-26272584-thumbnail.jpg?__SQUARESPACE_CACHEVERSION=1432995723469" alt="" /></a></span></span></p>
  <p>Peter M. DeLorenzo has been immersed in all things automotive since childhood. Privileged to be an up-close-and-personal witness to the glory days of the U.S. auto industry, DeLorenzo combines that historical legacy with his own 22-year career in automotive marketing and advertising to bring unmatched industry perspectives to the Internet with Autoextremist.com, which was founded on June 1, 1999. DeLorenzo is known for his incendiary commentaries and laser-accurate analysis of the automobile business, as well as racing and the business of motorsports. Author. Commentator. Influencer. The Consigliere. Minister of the High-Octane Truth. DeLorenzo is considered to be one of the most influential voices commenting on the business today.</p>
  <p>DeLorenzo's latest book is <em>Witch Hunt</em> (Octane Press&nbsp;       <a href="http://octanepress.com/book/page/witch-hunt-home" target="_blank">witchhuntbook.com</a>).  It is available on Amazon in both hardcover and Kindle formats, as well  as on iBookstore. DeLorenzo is also the author of&nbsp;<em>The United States of Toyota</em>.</p>
</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent981974" class="sectionWrapper promotedContainer "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

       <div class="caption">Navigation</div> 

      
        
          <ul class="content-navigation">
  <li class="module active-module  " id="moduleContentWrapper1858948">

    <div id="moduleContent1858948">

              <a id="moduleLink1858948" class=" " href="/" ><span>Rants</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper1882163">

    <div id="moduleContent1882163">

              <a id="moduleLink1882163" class=" " href="/on-the-table1/" ><span>On The Table</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper1882168">

    <div id="moduleContent1882168">

              <a id="moduleLink1882168" class=" " href="/fumes1/" ><span>Fumes</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper1882165">

    <div id="moduleContent1882165">

              <a id="moduleLink1882165" class=" " href="/the-line1/" ><span>The Line</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper1882171">

    <div id="moduleContent1882171">

              <a id="moduleLink1882171" class=" " href="/road-kill1/" ><span>A Bud&#39;s Life</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper1882448">

    <div id="moduleContent1882448">

              <a id="moduleLink1882448" class=" " href="/autoextremist-image-gallery/" ><span>Image Gallery</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper1882196">

    <div id="moduleContent1882196">

              <a id="moduleLink1882196" class=" " href="/emails-of-the-week1/" ><span>Reader Mail</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper1858949">

    <div id="moduleContent1858949">

              <a id="moduleLink1858949" class=" " href="/about-us/" ><span>About AE</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper1859799">

    <div id="moduleContent1859799">

              <a id="moduleLink1859799" class=" " href="/search-autoextremist/" ><span>Search AE</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper1859817">

    <div id="moduleContent1859817">

              <a id="moduleLink1859817" class=" " href="/contact-ae/" ><span>Contact AE</span></a>
      

      

    </div>

  </li>

</ul>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent981976" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

       <div class="caption">Follow Autoextremist</div> 

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper19208035" class="widget-wrapper  widget-type-page"><div id="moduleContent19208035">





  <p><span class="full-image-float-left ssNonEditable"><span><a href="http://www.facebook.com/autoextremist" target="_blank"><img src="/storage/FaceBook_24x24.png?__SQUARESPACE_CACHEVERSION=1359503380845" alt="" /></a></span></span><span class="full-image-float-left ssNonEditable"><span><a href="https://twitter.com/PeterMDeLorenzo" target="_blank"><img src="/storage/Twitter_24x24.png?__SQUARESPACE_CACHEVERSION=1359503367232" alt="" /></a></span></span><span class="full-image-float-left ssNonEditable"><span><a href="http://www.autoextremist.com/current/atom.xml" target="_blank"><img src="/storage/Feed_24x24.png?__SQUARESPACE_CACHEVERSION=1359503768995" alt="" /></a></span></span></p>
  <p>&nbsp;</p>
</div></div><div id="moduleContentWrapper19208015" class="widget-wrapper  widget-type-page"><div id="moduleContent19208015">





  <p><script type="text/javascript"><!--
  google_ad_client = "pub-6086244869615848";
  /* 160x600, created 8/4/08 */
  google_ad_slot = "3099506069";
  google_ad_width = 160;
  google_ad_height = 600;
  //-->
  </script> <script type="text/javascript"
  src="http://pagead2.googlesyndication.com/pagead/show_ads.js">
  </script></p>
</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

  

</div></div></div></div></div></div>
  <div id="sidebar2Wrapper" class="verticalNavigationBarWrapper"><div class="iw-vnb1"><div class="iw-vnb2"><div class="iw-vnb3"><div class="iw-vnb4"><div id="sidebar2" class="verticalNavigationBar">

  

  

</div></div></div></div></div></div>
  
  

  <div id="contentWrapper"><div id="content">
    
          
    


  

  
  
  
  
  <div class="single-journal-entry-wrapper">
    


<div class="journal-entry-wrapper post-text authored-by-wordgirl ">
<div id="item35955114" class="journal-entry">

  <div class="journal-entry-float-day"><span class="name">Monday</span></div><div class="journal-entry-float-date"><span class="month">Aug</span><span class="date">14</span><span class="year">2017</span></div>
  
  
  
  <div class="journal-entry-text">
  
      
      <h2 class="title">
    
        
    
        <a class="journal-entry-navigation-current" href="/current/2017/8/14/the-overhyped-the-overblown-and-the-overrated.html">THE OVERHYPED. THE OVERBLOWN. AND THE&nbsp;OVERRATED.</a>  
     
         
    
      </h2>
      
       <div class="journal-entry-tag journal-entry-tag-post-title"><span class="posted-on">   <img title="Date" alt="Date" class="inline-icon date-icon" rel="blk_ko_18" src="/universal/images/transparent.png" />Monday, August 14, 2017 at 06:29PM</span> </div> 

    
  
      
      <div class="body">
  
        
        
        
          <p><strong>Editor's Note:</strong> So, the Autoextremist says he's tired (exhausted       is more like it), and there is clearly more to be tired of than       ever before in this business. This week, things reach a fever       pitch with events leading up to both the Woodward Dream Cruise       here in Detroit and the monument to all things automotive that is       the Monterey Peninsula in August and its crown jewel, the Pebble       Beach Concours d'Elegance. To that end, this week's Rant continues       the ongoing theme of all that is wrong with the car enthusiast craze these days - and there is much to lament. (And       don't miss Peter's take on the latest from Acura and Infiniti in "<a href="http://www.autoextremist.com/on-the-table1/" target="_blank"><span style="text-decoration: underline;">On         The Table</span></a>.") It is impossible not to be cynical about the       sorry state of so much that defines the business today. But it is       also impossible not to be awestruck by a car that is       jaw-droppingly beautiful or outrageous or crazy or just plain       cool. Weird, right? No, it's one of those "don't hate the player,       hate the game" things. Because no matter how bad things get, there       is always one more car we've never seen before, one more car to       turn our heads, one more car to make a memory. And that's because       we absolutely love, love, <em>love</em> cars. -WG</p>
<p>&nbsp;</p>
<p><strong><em>By Peter M. DeLorenzo</em></strong></p>
<p><strong>Detroit. </strong>Since my column last         week (&ldquo;<a href="http://www.autoextremist.com/current/2017/8/8/tired-not-tired.html" target="_blank"><span style="text-decoration: underline;">Tired. Not Tired</span></a>.&rdquo;) seemed to have struck a nerve         and is still         jangling about the Autoverse, I have become even more         aggravated with the         state of the so-called car "thing" as it exists today. But it&rsquo;s         not         just the current sad state of the OEM kaleidoscope that&rsquo;s         frustrating. No, it's         clear that the car enthusiast culture - or what's left of it -         has been overrun         by con artists, spineless weasels, clueless marketing twerps,         greed merchants,         poseurs and too many (but not all) in the media who display more         go-along-to-get-along, "Thank you, sir, may I have another" cheerleading         than your average Big Ten home game in the fall.</p>
<p>Where is it all going? Nowhere good,         I'm afraid.&nbsp;</p>
<p>Just this past week we were subjected         to the site of normally rational (at least for the most part)         auto         &ldquo;journalists&rdquo; foaming at the mouth because FCA operatives staged         a media         preview of its &ldquo;Roadkill Nights,&rdquo; which allowed the         carpal-tunnel-challenged to         do real live &ldquo;burnouts&rdquo; in Dodge Challengers, Chargers and of         course the Demon,         as if this required a level of skill heretofore unknown to         contemporary life.</p>
<p>In case you need to be reminded,         &ldquo;Roadkill Nights&rdquo; is a creation of FCA that shuts down Woodward         Avenue in         Pontiac on the Saturday before the &ldquo;Dream Cruise&rdquo; so that legal         drag racing can         take place on a very abbreviated strip of asphalt. People can         pay their money         and drag race on the track, and a good time is had by all.         Except it was an         organic &ldquo;happening&rdquo; the first year when it was held in the         parking lot at the         abandoned Pontiac Silverdome, and somewhat novel the second year         when it was         relocated to Woodward, but it was by the third year &ndash; this year         &ndash; when various forms of         motorized &ldquo;entertainment&rdquo; were added and FCA leveraged         everything they had to         market their line of muscle cars, that it was played out.</p>
<p>That the media &ndash; both auto and         otherwise         &ndash; was completely enthralled by doing burnouts is beyond me, but         they dutifully         played into the FCA PR minion&rsquo;s hands by positively gushing over         everything         having to do with &ldquo;Roadkill Nights.&rdquo; I couldn&rsquo;t quite understand         it, unless of         course they signed a release beforehand stating that they must         surrender all         credibility at the gate before entering. It was that bad.</p>
<p>I&rsquo;m sure FCA operatives are slapping         themselves on the back this week as they celebrate the marketing         &ldquo;coup&rdquo; they         pulled off on behalf of their muscle car lineup, except that         it&rsquo;s only         indicative of the woefully warped bubble they&rsquo;ve created for         themselves.         Marketing a lineup of muscle cars with extremely narrow appeal         to an audience         of smoky burnout enthusiasts is nothing more than preaching to a         choir that&rsquo;s         getting smaller by the day. But hey, since Sergio is about to         sell out to         the Chinese lock, stock and barrel (as Peter has predicted for         years. See this         week&rsquo;s &ldquo;<a href="http://www.autoextremist.com/on-the-table1/" target="_blank"><span style="text-decoration: underline;">On The Table</span></a>&rdquo; &ndash;WG), maybe the prevailing attitude         out in Auburn         Hills is that they simply don&rsquo;t give a damn anymore.</p>
<p>But I digress. I&rsquo;m going to talk         about three things in this business that are overhyped,         overblown and         overrated. Things that need to be singled-out, dissected&hellip; and         hammered.</p>
<p><strong>1.           Fear and Loathing at &ldquo;Monterey Car Week.&rdquo;</strong> I&rsquo;m unhappy to         report that right this minute there are         shiny happy auto marketing troops out in Pebble Beach patting         themselves on the         back that they're present and accounted for at Monterey Car         Week, even though         the research gleaned and goodwill bestowed on prospects amounts         to a giant bowl         of Not So Much. As for the few brighter lights at the car         companies who realize         that the million-dollar bills they accrue at Pebble Beach really         don't add up         to much of anything quantifiable, they're unfortunately offset         by the marketers         who are whining because they aren't there and who can't wait to         get out there         next year. So the cycle is likely to continue.&nbsp;</p>
<p>&ldquo;Monterey Car Week&rdquo; has become an an         excellent indicator that luxury automakers and their marketing         troops are         completely out of ideas when it comes to marketing their wares,         and you only         have to look as far as the week of over-the-top events going on right now on the         Monterey         Peninsula.</p>
<p>The relentless, ever-present din that         hangs in the air out there is defined by         the drunken spending among the luxury automakers and         unremarkably enough, the         way they go about it has the stench of sameness attached to it         that in the end         makes it indistinguishable from one brand to another. It&rsquo;s the         same luxury accoutrements, the same rote regurgitation of         &ldquo;luxury&rdquo;         words and phrases that are mumbled in an interchangeable         soundtrack from brand         to brand, and the same platitudes and cloying familiarity that         blend together         in a dismal cadence of vacuousness that goes by like a blur of         marketing         cotton candy, a fleeting sugar rush of pseudo substance followed         by the         inevitable crash of emptiness.</p>
<p>Yet automakers drop, collectively, at         least a hundred million dollars like clockwork out in         Monterey every year. Why? Because, as I&rsquo;ve stated         before, the         lingering question hanging over the marketing troops isn&rsquo;t         &ldquo;Maybe we ought to         reevaluate this whole thing&rdquo; but,&nbsp;&ldquo;What happens if we&rsquo;re&nbsp;<em>not</em>&nbsp;there?&rdquo;</p>
<p>Which isn&rsquo;t exactly an answer that         makes a lick of sense, now does it?</p>
<p><strong>2. The calculated feeding frenzy           manufactured by the auto auction houses has decimated the           fundamental           enthusiasm that used to define car enthusiasts of all           stripes.&nbsp;</strong>There, I said<strong>&nbsp;</strong>it. The         whole auto auction game has graduated from being merely tedious         to a threat to         car enthusiasm itself. Speaking of something not making a lick         of sense, the         fevered business surrounding auto auctions has come to define         the car &ldquo;hobby&rdquo;         for a lot of people, which is a&nbsp;<em>very </em>bad thing.<strong>&nbsp;</strong>Why?         Because it&rsquo;s not about the cars anymore, or the fleeting moments         in time that defined         what those machines represented, or the memories they created         for the         enthusiasts who drove them. No, it&rsquo;s about flat-out greed, pure         and simple.</p>
<p>Whether it&rsquo;s resurrected cars         over-restored to perfection or &ldquo;survivor&rdquo; cars         brokered &ldquo;as is&rdquo; it&rsquo;s really all the same. It&rsquo;s a circus of         artificial         enthusiasm marked by overheated auction hucksters in cahoots         with the blatant         sycophants at the TV networks who all do their very best to add         to the faux         cacophony, which is only punctuated by the projected &ldquo;record&rdquo;         dollar figures         that seemingly get attached to every car. (The usurious buyers&rsquo;         and sellers&rsquo; premiums are barely         mentioned.) &nbsp;</p>
<p>Car auctions have destroyed the last         vestige of rational thought that was once         associated with being a car enthusiast. In fact, rational         thinking when it         comes to the car enthusiast experience was steadily reduced to         collateral         damage years and years ago by the &ldquo;greed merchants&rdquo; at the         auction houses. And         it really stinks.</p>
<p>As if to emphasize the point, in the         last few weeks we have received an unending series of come-ons         from the auction         houses that tout the latest and greatest cars, all of which are         pegged at         absurd bid levels, and it frankly leaves me cold. There is no         excitement generated by         these communiqu&eacute;s, just a gloomy emptiness hanging in the air         over machines         that once brimmed with passion and creativity, but are now         relegated to marks         on a ledger, which will count toward a tally that will be used         to promote&nbsp;<em>next</em>&nbsp;year's         installment of the circus.</p>
<p>This tedious drill went far beyond         the "Fools and their money..." adage well over two decades ago.         These         machines are paraded on stage - souls removed - only to end up         in antiseptic,         "perfect" garages until they're prepared for another auction         down the         road. This isn't about the car culture or the sheer passion once         associated         with these automobiles; no, now it's the living, breathing         embodiment of Greed         is Good.</p>
<p><strong>3. And last but not least there&rsquo;s           our           very own &ldquo;Dream Cruise,&rdquo; the annual car happening in August           that went from being           a spontaneous celebration of the automobile to an event           wearing a leaded cloak           of marketing sameness as orchestrated by the manufacturers and           suppliers.</strong>&nbsp;Yeah, it&rsquo;s really too bad, but         the High-Octane Truth about the Dream Cruise is that it simply         doesn&rsquo;t ring         true anymore, as unpopular as that notion might be with some         around here. The         spontaneity that once bubbled up organically in the early years         has been         replaced by manufacturer displays, manufacturer &ldquo;drive-bys&rdquo; (the         novelty of 50         cars of the same make driving up and down Woodward Avenue was         never, ever, cool         - trust me), and a rigid sameness that is as predictable as the         local media         coverage of the event, which is nothing but a regurgitation of         the last         decade&rsquo;s worth (at least) of stories.</p>
<p>The Dream Cruise has been overhyped,         overblown and overrated for years, just like Monterey Car Week.         I reserve         particular ire for some of the card-carrying members of the         local media who         fall over themselves trying to pump up the volume on the latest         edition, when a sameness hangs over the proceedings in a giant         haze         of "we've seen this all before, right?" Then         again, when the local media collectively defines the term         journalistic &ldquo;homers&rdquo;         it should be no surprise at all.</p>
<p>The drill is the same every year. The         manufacturers and suppliers mark their territories along         Woodward Avenue, which         means any anticipation is missing in action, with the whole         thing having been         reduced to an annual dirge of predictability. Is this really         what this business         has come to in the "Motor City"? Is this "celebration" of         our car culture the best we can do? I certainly hope not,         because it has all of         the spontaneity of the grim "back to school" ads polluting the         airwaves right now.</p>
<p>So, at the end of this discussion a         giant question remains. Is the car enthusiast thing a lost         cause? Are we really going to slink off and wait for autonomy to         put us out of our collective misery once and for all? Not by a         long shot, thankfully. But those three aforementioned subjects         should force everyone to take stock and remember the following         very important         points.</p>
<p>You have to love the car business.         Well, let me rephrase that.&nbsp;<em>Some</em>&nbsp;of us immersed in this         seething cauldron of runaway egos, shortsightedness,         intermittent brilliance         and, remarkably enough and against all odds, indomitable spirit,         love this         business. (Then again, when it comes right down to it, it         depends on the day.)</p>
<p>We love it for the unbridled         creativity demonstrated by its True Believers, who keep stepping         up to the         plate and swinging for the fences. We love it for the relentless         24/7 churn &ndash;         and associated weariness - that it entails (even though everyone         complains about         it, they wouldn&rsquo;t have it any other way).</p>
<p>We love it for the brief shining         moments when an exceptional design or product advancement         emerges to remind us         all of what turned us on about the business in the first place,         even though         those moments are fleeting, at best.</p>
<p>But then again and truth be told, we         love to loathe it too. It can&rsquo;t be helped. We despise the carpetbagging         mercenaries who seem to rear their ugly heads at the most         inopportune moments         to wreak havoc on this business. Oh, you know who I&rsquo;m referring         to, that         &ldquo;Murderer&rsquo;s Row&rdquo; of malicious connivers, "Minimum Bob&rdquo;         Nardelli, &ldquo;Captain Queeg&rdquo; Akerson and Sergio the &ldquo;G.O.A.T.&rdquo; just         to name a few.</p>
<p>We cringe at the legions of spineless         weasels that populate almost every corner         of this business, the go-along-to-get-along hordes and dutiful,         sniveling         minions who project a positive demeanor but who wallow in         serial, abject         mediocrity at every turn. That part of the business is <em>always</em> depressing and tedious,         there&rsquo;s no doubt.</p>
<p>But yet, we press on. And for good         reason too.</p>
<p>Yes, the overhyped, overblown and         overrated aspects of this business, which we loathe, aren&rsquo;t         going away any time         soon.</p>
<p>But fortunately the fundamental         enthusiasm displayed by the True Believers and everyday         enthusiasts alike who         still like &ndash; make that <em>love</em> &ndash;         everything to do with the automobile isn&rsquo;t going away any time         soon, either.</p>
<p>Thank         goodness.</p>
<p>And that&rsquo;s the High-Octane Truth for         this week.</p>

        
  
          
  
         
  
      </div>

    

  </div>

      <div class="journal-entry-tag journal-entry-tag-post-body">
      <div class="journal-entry-tag-post-body-line1"><span class="posted-by">  <a href="/current/author/wordgirl"> <img title="Author" alt="Author" class="inline-icon user-registered-icon" rel="blk_ko_18" src="/universal/images/transparent.png" />Editor</a></span> |  <span class="share-item"><a href="javascript:noop();" onclick="Squarespace.Interaction.shareLink(this,'%2Fcurrent%2F2017%2F8%2F14%2Fthe-overhyped-the-overblown-and-the-overrated.html','THE%20OVERHYPED.%20THE%20OVERBLOWN.%20AND%20THE%20OVERRATED.');"> <img title="Share Article" alt="Share Article" class="inline-icon share-icon" rel="blk_ko_18" src="/universal/images/transparent.png" />Share Article </a></span> |  <span class="email-item"><a href="/current/recommend/35955114"> <img title="Email Article" alt="Email Article" class="inline-icon email-icon" rel="blk_ko_18" src="/universal/images/transparent.png" />Email Article </a></span> |  <span class="print-item"><a href="/current/2017/8/14/the-overhyped-the-overblown-and-the-overrated.html?printerFriendly=true"> <img title="Print Article" alt="Print Article" class="inline-icon print-icon" rel="blk_ko_18" src="/universal/images/transparent.png" />Print Article </a></span> </div>
      <div class="journal-entry-tag-post-body-line2"></div>
      <div class="journal-entry-tag-post-body-line3"></div>
    </div>
  
  
  <div class="clearer"></div>

</div>
</div>





  </div>

  

  

      
  <div class="journal-entry-navigation">

    
      
      <a class="journal-entry-navigation-main" href="/current/">Main</a>
       | <a class="journal-entry-navigation-next" href="/current/2017/8/8/tired-not-tired.html">TIRED. NOT TIRED. &raquo;</a> 

    

  </div>


  

  

  
  

  


  

  

  
  

</div></div> <!-- Content -->
  
    
  
    </div></div> <!-- Page Body -->

    
    
    <div id="pageFooterWrapper"><div id="pageFooter">
  
              <a href="/current/">RANTS</a>  |  <a href="/on-the-table1/">ON THE TABLE</a>  |  <a href="/fumes1/">FUMES</a>  |  <a href="/the-line1/">THE LINE</a>  |  <a href="/road-kill1/">A BUD'S LIFE</a>  | <a href="/emails-of-the-week1/"> READER MAIL</a>  <br><br>

THE UNAUTHORIZED USE OF ANY EDITORIAL OR PHOTOGRAPHIC CONTENT FROM AUTOEXTREMIST.COM WITHOUT WRITTEN PERMISSION FROM THE PUBLISHER IS STRICTLY PROHIBITED.<br>
<a href="/copyright/">Copyright Statement</a> ~ © 1999-2017 Autoextremist.com, Inc. ~ <a href="/privacy-policy/">Privacy Policy</a>
      
  
      
  
    </div></div>
  
  </div></div> <!-- Canvas -->
  
   


  <div class="clearer" id="bodyClearer"></div>

  



</body>
</html>