<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">

<head>
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8"/> 
  
   <meta name="Robots" content="index,follow" />  
  
  
  <!-- autoextremist -->

  <link rel="shortcut icon" href="/favicon.ico" type="image/x-icon" />

  <link id="primaryStylesheet" rel="stylesheet" type="text/css" href="/display/common.css?styleId=1814361&amp;RK=1359510686127&amp;CE=75"/>
  
  <link id="slideShowStylesheet" rel="stylesheet" type="text/css" href="/universal/styles/squarespace-gallery-slideshow.css?CE=75"/>
  
  
    <link rel="alternate" type="application/atom+xml" title="ATOM" href="http://www.autoextremist.com/current/atom.xml" />
  
    <link rel="alternate" type="application/rss+xml" title="RSS" href="http://www.autoextremist.com/current/rss.xml" />
  
    <link rel="alternate" type="application/rdf+xml" title="RDF" href="http://www.autoextremist.com/current/rdf.xml" />
  
  
  <!-- Google Web Fonts -->
  <script type="text/javascript">
    	WebFontConfig = {"google": {"families": ["Josefin Sans:400"]}};
  
   
    (function() {
      var wf = document.createElement('script');
      wf.src = ('https:' == document.location.protocol ? 'https' : 'http') +
          '://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';
      wf.type = 'text/javascript';
      wf.async = 'true';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(wf, s);
    })();
  </script>

  <script type="text/javascript" src="/universal/yui/yahoo-dom-event/yahoo-dom-event.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/connection/connection_core-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/json/json-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/animation/animation-min.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/selector/selector.js?CE=75"></script>
<script type="text/javascript" src="/universal/yui/element/element.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/global.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/lightbox.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/api.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/base64.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/census.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/yui2-yui3-bridge.js?CE=75"></script>
<script type="text/javascript" src="/universal/scripts/squarespace-gallery-slideshow.js?CE=75"></script>


  <script type="text/javascript">
  // <![CDATA[

    Squarespace.Constants.SS_AUTHKEY = encodeURIComponent("");
    Squarespace.Constants.WEBSITE_TITLE =  "Autoextremist.com"; 
    
     Squarespace.Constants.CURRENT_MODULE_ID = "1858948"; 
    
    
    
    Squarespace.Constants.ADMINISTRATION_UI =  false; 
    
    
     Squarespace.Constants.OBJECT_PERMALINK = "http://www.autoextremist.com/current/2018/4/2/the-good-the-bad-and-the-mostly-ugly-from-the-new-york-auto.html"; 
    Squarespace.Constants.CORE_APPLICATION_DOMAIN = "squarespace.com";
    Squarespace.Constants.CORE_V6_APPLICATION_DOMAIN = "squarespace.com";
    Squarespace.Constants.V5_FRONTSITE = "http://five.squarespace.com";
    Squarespace.Constants.WEBSITE_ID = "192288";

    

    

    

  // ]]>
  </script>

      <title>THE GOOD, THE BAD AND THE MOSTLY UGLY FROM THE NEW YORK AUTO&nbsp;SHOW. - Rants - Autoextremist.com ~ the bare-knuckled, unvarnished, high octane truth...</title>
    <meta property="og:title" content="THE GOOD, THE BAD AND THE MOSTLY UGLY FROM THE NEW YORK AUTO&nbsp;SHOW. - Rants - Autoextremist.com ~ the bare-knuckled, unvarnished, high octane truth..." /> 
  

      <meta property="og:description" content=" By Peter M. DeLorenzo 

 Detroit.  In the aftermath of the New York Auto Show, it&amp;rsquo;s clea..." />
  

  
      <meta property="og:image" content="http://www.autoextremist.com/storage/2018 New York International Auto Show Cadillac X14-2.jpg?__SQUARESPACE_CACHEVERSION=1522677398235" />
  
      <meta property="og:image" content="http://www.autoextremist.com/storage/2018 New York International Auto Show Cadillac CT6 VSport-8.jpg?__SQUARESPACE_CACHEVERSION=1522677422137" />
  
      <meta property="og:image" content="http://www.autoextremist.com/storage/Lincoln-Aviator-01.jpg?__SQUARESPACE_CACHEVERSION=1522677449474" />
  
      <meta property="og:image" content="http://www.autoextremist.com/storage/Lincoln-Aviator-12.jpg?__SQUARESPACE_CACHEVERSION=1522677471993" />
  
      <meta property="og:image" content="http://www.autoextremist.com/storage/Lincoln-Aviator-16.jpg?__SQUARESPACE_CACHEVERSION=1522677495060" />
  
      <meta property="og:image" content="http://www.autoextremist.com/storage/1271-TheGenesisEssentiaConceptathoroughlymoderninterpretationofahighlydesirableclassicGranTurismo.jpg?__SQUARESPACE_CACHEVERSION=1522677563452" />
  
      <meta property="og:image" content="http://www.autoextremist.com/storage/Large-1272-Theall-electrichigh-performanceEssentiaConceptelevatesandreimaginestheGenesisAthleticElegancedesignparadigmwhileprovidingavisionoffutureGenesisproductperformanceandtechnology.jpg?__SQUARESPACE_CACHEVERSION=1522677608633" />
  
      <meta property="og:image" content="http://www.autoextremist.com/storage/2019-GMC-Sierra-AT4-025.jpg?__SQUARESPACE_CACHEVERSION=1522677758858" />
  
      <meta property="og:image" content="http://www.autoextremist.com/storage/2018 New York International Auto Show Acura RDX-4.jpg?__SQUARESPACE_CACHEVERSION=1522677780055" />
  
      <meta property="og:image" content="http://www.autoextremist.com/storage/2018 New York International Auto Show Porsche-3.jpg?__SQUARESPACE_CACHEVERSION=1522677806899" />
  

  <!-- End Heading -->

  <META NAME="Keywords" CONTENT="automotive news, automotive commentary, auto racing, automobile industry, auto industry,Ford, Chevrolet, GM, Toyota, Buick, Nissan, Volkswagen, Porsche, Audi, Honda, Pontiac, Chrylser, Damlier, Mercedes"/>
<META NAME="Author" CONTENT="johnt@c2group.com"/>


  <script type="text/javascript" src="/universal/scripts/cookie-min.js"></script>
  <script type="text/javascript" src="/universal/scripts/eu-cookie-policy.js"></script>

</head>

<body  id="modulePage1858948"   class="objectId36052717"  >

  <script type="text/javascript">
  YAHOO.util.Event.onDOMReady(function() {
    if (document.location.href.indexOf("SSLogoutOk=true") != -1) {
      new Squarespace.FixedPositionTip("Logout Successful", "You have been successfully logged out.", { xMargin: 15, yMargin: 15, icon: "/universal/images/helptip-info.png", orientation: "upper-right", viewportFixed: true, autoHide: 1800 }).show();
    }
  });
</script>

    

  <script type="text/javascript">
    YAHOO.util.Event.onDOMReady(function() { new Squarespace.Census.hit(); } );
  </script>

  <script type="text/javascript">
    YAHOO.util.Event.addListener(document, "keyup", function (e) { if (!e) { e = event; } if (e.keyCode == 27) { document.location.href = "/login/?returnUrl=%2Fcurrent%2F2018%2F4%2F2%2Fthe-good-the-bad-and-the-mostly-ugly-from-the-new-york-auto.html"; } });
  </script>




  

  <div id="canvasWrapper"><div id="canvas">
  
  

  <div id="pageHeaderWrapper"><div id="pageHeader">

      <div id="navigationTop"><div id="navigationTop-sectionContent981974" class="horizontalNavigationBar"><ul class="content-navigation">
    
  <li class="module active-module  " id="navigationTop-moduleContentWrapper1858948">

    <div id="navigationTop-moduleContent1858948">

              <a id="navigationTop-moduleLink1858948" class=" " href="/" ><span>Rants</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper1882163">

    <div id="navigationTop-moduleContent1882163">

              <a id="navigationTop-moduleLink1882163" class=" " href="/on-the-table1/" ><span>On The Table</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper1882168">

    <div id="navigationTop-moduleContent1882168">

              <a id="navigationTop-moduleLink1882168" class=" " href="/fumes1/" ><span>Fumes</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper1882165">

    <div id="navigationTop-moduleContent1882165">

              <a id="navigationTop-moduleLink1882165" class=" " href="/the-line1/" ><span>The Line</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper1882448">

    <div id="navigationTop-moduleContent1882448">

              <a id="navigationTop-moduleLink1882448" class=" " href="/autoextremist-image-gallery/" ><span>Image Gallery</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper1882196">

    <div id="navigationTop-moduleContent1882196">

              <a id="navigationTop-moduleLink1882196" class=" " href="/emails-of-the-week1/" ><span>Reader Mail</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper1858949">

    <div id="navigationTop-moduleContent1858949">

              <a id="navigationTop-moduleLink1858949" class=" " href="/about-us/" ><span>About AE</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper1859799">

    <div id="navigationTop-moduleContent1859799">

              <a id="navigationTop-moduleLink1859799" class=" " href="/search-autoextremist/" ><span>Search AE</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationTop-moduleContentWrapper1859817">

    <div id="navigationTop-moduleContent1859817">

              <a id="navigationTop-moduleLink1859817" class=" " href="/contact-ae/" ><span>Contact AE</span></a>
      

      

    </div>

  </li>


  </ul><br class="clearer"/></div></div>

    
        
      
  
      <div id="bannerAreaWrapper"><div id="bannerArea">

        
        <div id="bannerWrapper">
          <a href="http://www.autoextremist.com/"><img id="banner" src="/storage/autoX_banner.jpg" alt="Autoextremist.com" title="Autoextremist.com"/></a>
        </div>  

      
      
      </div></div>
    
    
    

      <div id="navigationBottom"><div id="navigationBottom-sectionContent981974" class="horizontalNavigationBar"><ul class="content-navigation">
    
  <li class="module active-module  " id="navigationBottom-moduleContentWrapper1858948">

    <div id="navigationBottom-moduleContent1858948">

              <a id="navigationBottom-moduleLink1858948" class=" " href="/" ><span>Rants</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper1882163">

    <div id="navigationBottom-moduleContent1882163">

              <a id="navigationBottom-moduleLink1882163" class=" " href="/on-the-table1/" ><span>On The Table</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper1882168">

    <div id="navigationBottom-moduleContent1882168">

              <a id="navigationBottom-moduleLink1882168" class=" " href="/fumes1/" ><span>Fumes</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper1882165">

    <div id="navigationBottom-moduleContent1882165">

              <a id="navigationBottom-moduleLink1882165" class=" " href="/the-line1/" ><span>The Line</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper1882448">

    <div id="navigationBottom-moduleContent1882448">

              <a id="navigationBottom-moduleLink1882448" class=" " href="/autoextremist-image-gallery/" ><span>Image Gallery</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper1882196">

    <div id="navigationBottom-moduleContent1882196">

              <a id="navigationBottom-moduleLink1882196" class=" " href="/emails-of-the-week1/" ><span>Reader Mail</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper1858949">

    <div id="navigationBottom-moduleContent1858949">

              <a id="navigationBottom-moduleLink1858949" class=" " href="/about-us/" ><span>About AE</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper1859799">

    <div id="navigationBottom-moduleContent1859799">

              <a id="navigationBottom-moduleLink1859799" class=" " href="/search-autoextremist/" ><span>Search AE</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="navigationBottom-moduleContentWrapper1859817">

    <div id="navigationBottom-moduleContent1859817">

              <a id="navigationBottom-moduleLink1859817" class=" " href="/contact-ae/" ><span>Contact AE</span></a>
      

      

    </div>

  </li>


  </ul><br class="clearer"/></div></div>


  </div></div>
  
  

  

  
  <div id="pageBodyWrapper"><div id="pageBody">
  
  <div id="sidebar1Wrapper" class="verticalNavigationBarWrapper"><div class="iw-vnb1"><div class="iw-vnb2"><div class="iw-vnb3"><div class="iw-vnb4"><div id="sidebar1" class="verticalNavigationBar">

  

    <div id="sectionContent981973" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper1859818" class="widget-wrapper  widget-type-page"><div id="moduleContent1859818">





  <hr />
  <div align="center" style="text-align: center;">No. 940</div>
  <div align="center" style="text-align: center;">April 4, 2018</div>
  <div align="center" style="text-align: center;"><span style="font-family: Arial;"><span class="ssNonEditable full-image-block">&nbsp;</span></span></div>
  <hr />
</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent8144685" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

      

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper19455702" class="widget-wrapper  widget-type-page"><div id="moduleContent19455702">





  <h3>About The Autoextremist</h3>
  <p><span class="thumbnail-image-block ssNonEditable"><span><a href="javascript:showFullImage('/display/ShowImage?imageUrl=%2Fstorage%2Fpmd15-26.jpg%3F__SQUARESPACE_CACHEVERSION%3D1432995723468',1024,991);"><img src="/storage/thumbnails/1858946-26272584-thumbnail.jpg?__SQUARESPACE_CACHEVERSION=1432995723469" alt="" /></a></span></span></p>
  <p>Peter M. DeLorenzo has been immersed in all things automotive since childhood. Privileged to be an up-close-and-personal witness to the glory days of the U.S. auto industry, DeLorenzo combines that historical legacy with his own 22-year career in automotive marketing and advertising to bring unmatched industry perspectives to the Internet with Autoextremist.com, which was founded on June 1, 1999. DeLorenzo is known for his incendiary commentaries and laser-accurate analysis of the automobile business, as well as racing and the business of motorsports. Author. Commentator. Influencer. The Consigliere. Minister of the High-Octane Truth. DeLorenzo is considered to be one of the most influential voices commenting on the business today.</p>
  <p>DeLorenzo's latest book is <em>Witch Hunt</em> (Octane Press&nbsp;       <a href="http://octanepress.com/book/page/witch-hunt-home" target="_blank">witchhuntbook.com</a>).  It is available on Amazon in both hardcover and Kindle formats, as well  as on iBookstore. DeLorenzo is also the author of&nbsp;<em>The United States of Toyota</em>.</p>
</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent981974" class="sectionWrapper promotedContainer "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

       <div class="caption">Navigation</div> 

      
        
          <ul class="content-navigation">
  <li class="module active-module  " id="moduleContentWrapper1858948">

    <div id="moduleContent1858948">

              <a id="moduleLink1858948" class=" " href="/" ><span>Rants</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper1882163">

    <div id="moduleContent1882163">

              <a id="moduleLink1882163" class=" " href="/on-the-table1/" ><span>On The Table</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper1882168">

    <div id="moduleContent1882168">

              <a id="moduleLink1882168" class=" " href="/fumes1/" ><span>Fumes</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper1882165">

    <div id="moduleContent1882165">

              <a id="moduleLink1882165" class=" " href="/the-line1/" ><span>The Line</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper1882448">

    <div id="moduleContent1882448">

              <a id="moduleLink1882448" class=" " href="/autoextremist-image-gallery/" ><span>Image Gallery</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper1882196">

    <div id="moduleContent1882196">

              <a id="moduleLink1882196" class=" " href="/emails-of-the-week1/" ><span>Reader Mail</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper1858949">

    <div id="moduleContent1858949">

              <a id="moduleLink1858949" class=" " href="/about-us/" ><span>About AE</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper1859799">

    <div id="moduleContent1859799">

              <a id="moduleLink1859799" class=" " href="/search-autoextremist/" ><span>Search AE</span></a>
      

      

    </div>

  </li>


  <li class="module   " id="moduleContentWrapper1859817">

    <div id="moduleContent1859817">

              <a id="moduleLink1859817" class=" " href="/contact-ae/" ><span>Contact AE</span></a>
      

      

    </div>

  </li>

</ul>

        

      
  
    </div></div></div></div></div></div>

  

    <div id="sectionContent981976" class="sectionWrapper  "><div class="iw-s1"><div class="iw-s2"><div class="iw-s3"><div class="iw-s4"><div class="section">

       <div class="caption">Follow Autoextremist</div> 

      
        
          <div class="content-passthrough"><div id="moduleContentWrapper19208035" class="widget-wrapper  widget-type-page"><div id="moduleContent19208035">





  <p><span class="full-image-float-left ssNonEditable"><span><a href="http://www.facebook.com/autoextremist" target="_blank"><img src="/storage/FaceBook_24x24.png?__SQUARESPACE_CACHEVERSION=1359503380845" alt="" /></a></span></span><span class="full-image-float-left ssNonEditable"><span><a href="https://twitter.com/PeterMDeLorenzo" target="_blank"><img src="/storage/Twitter_24x24.png?__SQUARESPACE_CACHEVERSION=1359503367232" alt="" /></a></span></span><span class="full-image-float-left ssNonEditable"><span><a href="http://www.autoextremist.com/current/atom.xml" target="_blank"><img src="/storage/Feed_24x24.png?__SQUARESPACE_CACHEVERSION=1359503768995" alt="" /></a></span></span></p>
  <p>&nbsp;</p>
</div></div><div id="moduleContentWrapper19208015" class="widget-wrapper  widget-type-page"><div id="moduleContent19208015">





  <p><script type="text/javascript"><!--
  google_ad_client = "pub-6086244869615848";
  /* 160x600, created 8/4/08 */
  google_ad_slot = "3099506069";
  google_ad_width = 160;
  google_ad_height = 600;
  //-->
  </script> <script type="text/javascript"
  src="http://pagead2.googlesyndication.com/pagead/show_ads.js">
  </script></p>
</div></div></div>

        

      
  
    </div></div></div></div></div></div>

  

  

</div></div></div></div></div></div>
  <div id="sidebar2Wrapper" class="verticalNavigationBarWrapper"><div class="iw-vnb1"><div class="iw-vnb2"><div class="iw-vnb3"><div class="iw-vnb4"><div id="sidebar2" class="verticalNavigationBar">

  

  

</div></div></div></div></div></div>
  
  

  <div id="contentWrapper"><div id="content">
    
          
    


  

  
  
  
  
  <div class="single-journal-entry-wrapper">
    


<div class="journal-entry-wrapper post-text authored-by-wordgirl ">
<div id="item36052717" class="journal-entry">

  <div class="journal-entry-float-day"><span class="name">Monday</span></div><div class="journal-entry-float-date"><span class="month">Apr</span><span class="date">02</span><span class="year">2018</span></div>
  
  
  
  <div class="journal-entry-text">
  
      
      <h2 class="title">
    
        
    
        <a class="journal-entry-navigation-current" href="/current/2018/4/2/the-good-the-bad-and-the-mostly-ugly-from-the-new-york-auto.html">THE GOOD, THE BAD AND THE MOSTLY UGLY FROM THE NEW YORK AUTO&nbsp;SHOW.</a>  
     
         
    
      </h2>
      
       <div class="journal-entry-tag journal-entry-tag-post-title"><span class="posted-on">   <img title="Date" alt="Date" class="inline-icon date-icon" rel="blk_ko_18" src="/universal/images/transparent.png" />Monday, April 2, 2018 at 09:46AM</span> </div> 

    
  
      
      <div class="body">
  
        
        
        
          <p><strong><em>By Peter M. DeLorenzo</em></strong></p>
<p><strong>Detroit.</strong>&nbsp;In the aftermath of the New York Auto Show, it&rsquo;s clear that just showing up still counts for something in this business in some circles, which is beyond unfortunate. But being present and accounted for doesn&rsquo;t constitute a marketing strategy, or a bold reach &ndash;&nbsp;it&rsquo;s just showing up.&nbsp;</p>
<p>This was most evident in the introduction of the&nbsp;<strong>Cadillac XT4</strong>, which is an homage to the uninspired and expected, and living, breathing proof that Cadillac is utterly lacking in originality at this juncture. One look at the cohesive visual brilliance of the Jaguar I-Pace will tell you just how much GM Design phoned it in with the XT4. (See more of Peter&rsquo;s comments about the New York Auto Show in &ldquo;<span style="text-decoration: underline;"><a href="http://www.autoextremist.com/on-the-table1/" target="_blank">On The Table</a></span>&rdquo; -WG)&nbsp;</p>
<p><span class="full-image-block ssNonEditable"><span><img src="/storage/2018 New York International Auto Show Cadillac X14-2.jpg?__SQUARESPACE_CACHEVERSION=1522677398235" alt="" /><br />(newspressUSA) <br /><strong>The Cadillac XT4.</strong></span></span></p>
<p>And the&nbsp;<strong>CT6 V-Sport</strong>&nbsp;doesn&rsquo;t change my opinion of Cadillac one iota. It&rsquo;s a niche of a niche machine that means nothing for the brand&rsquo;s tenuous upward trajectory, because Cadillac is now mirroring Buick in that it exists for the Chinese market, and everything else is just going through the motions. Which is why its racing program is vaporware and why its entire high-performance push exists in a vacuum that means exactly nothing. I have been saying this for at least four years now: Corvette should become its own division within GM and all of Cadillac&rsquo;s V performance cars &ndash; which&nbsp;<em>are</em>&nbsp;outstanding &ndash;&nbsp;should be rebranded as Corvettes, because those cars are nonsensical with a Cadillac badge.&nbsp;</p>
<p><span class="full-image-block ssNonEditable"><span><img src="/storage/2018 New York International Auto Show Cadillac CT6 VSport-8.jpg?__SQUARESPACE_CACHEVERSION=1522677422137" alt="" /><br />(newspressUSA)<br /><strong>The Cadillac CT6 V-Sport.</strong><span style="font-size: 12px;">&nbsp;</span></span></span></p>
<p>But then again that&rsquo;s not all that&rsquo;s wrong with Cadillac. You only have to look at the new 2019&nbsp;<strong>Lincoln Aviator&nbsp;</strong>to see that Cadillac is about to get its ass handed to it in the market. Everything about the Aviator is slick and silky smooth, from its tapered profile to its exquisite interior, this SUV has hit written all over it. And Lincoln&rsquo;s rejuvenated embrace of real, actual names for its vehicles is going to pay massive dividends in the market as well, while Johan de Nysschen&rsquo;s continued quest to remake Cadillac in Audi&rsquo;s image &ndash; complete with coldly uninvolving alphanumeric nomenclature &ndash; is resonating with no one. Just a reminder: what is Cadillac&rsquo;s most sought-after product (besides the internally ignored old school XTS sedan)? The Escalade. There&rsquo;s a reason for that, but it&rsquo;s just too bad that Cadillac operatives simply don&rsquo;t get it.</p>
<p><span class="full-image-block ssNonEditable"><span><img src="/storage/Lincoln-Aviator-01.jpg?__SQUARESPACE_CACHEVERSION=1522677449474" alt="" /><br />(Lincoln)<br /><strong>The Lincoln Aviator.</strong></span></span></p>
<p><span class="full-image-block ssNonEditable"><span><img src="/storage/Lincoln-Aviator-12.jpg?__SQUARESPACE_CACHEVERSION=1522677471993" alt="" /><br />(Lincoln)<br /><strong>The Lincoln Aviator.</strong></span></span></p>
<p><span class="full-image-block ssNonEditable"><strong><img src="/storage/Lincoln-Aviator-16.jpg?__SQUARESPACE_CACHEVERSION=1522677495060" alt="" /></strong><br />(Lincoln)<br /><strong style="font-weight: bold;">The Lincoln Aviator.</strong></span></p>
<p><strong> </strong></p>
<p>And another thing wrong with the XT4?&nbsp;Cadillac PR minions chose to use the hoary "First Ever" moniker in its communications, which is hands-down the most tedious and unoriginal buzz phrase in current PR speak. Sad to say that they are not alone, because Ford is running launch advertising for its EcoSport subcompact SUV with the words &ldquo;First Ever&rdquo; figuring prominently. It&rsquo;s like a plague or something and I find it depressing that a total lack of originality seems to be running rampant throughout the business right now. This just in: &ldquo;First Ever&rdquo; means absolutely nothing, you unmitigated hacks. Get a new idea, and quick.</p>
<p>In other news from New York,&nbsp;<strong>Hyundai</strong>&nbsp;unveiled a magnificent piece of vaporware for its&nbsp;<strong>Genesis</strong>&nbsp;brand with its Essentia Concept. (See it &ldquo;<span style="text-decoration: underline;"><a href="http://www.autoextremist.com/on-the-table1/" target="_blank">On The Table</a></span>&rdquo; -WG) It&rsquo;s nicely rendered and executed, but it does nothing to quell the feeling Genesis dealers have that the brand is in disarray and that the whole thing is hanging by a thread. They&rsquo;re right, of course. Hyundai arrogance and hubris &ndash;&nbsp;which are so deeply ingrained that they are part of the brand's soul &ndash;&nbsp;have led Hyundai operatives to botch the introduction of the Genesis brand from the get-go, and they&rsquo;re&nbsp;<em>still</em>&nbsp;throwing ideas up against the wall to see what sticks. If Genesis continues floundering the brand will disappear into the ether by 2020.<span style="font-size: 12px;">&nbsp;</span></p>
<p><span class="full-image-block ssNonEditable"><strong><img src="/storage/1271-TheGenesisEssentiaConceptathoroughlymoderninterpretationofahighlydesirableclassicGranTurismo.jpg?__SQUARESPACE_CACHEVERSION=1522677563452" alt="" /></strong><br />(newspressUSA)<br /><strong style="font-weight: bold;"><span>The Genesis Essentia Concept.</span></strong></span></p>
<p><span class="full-image-block ssNonEditable"><strong><img src="/storage/Large-1272-Theall-electrichigh-performanceEssentiaConceptelevatesandreimaginestheGenesisAthleticElegancedesignparadigmwhileprovidingavisionoffutureGenesisproductperformanceandtechnology.jpg?__SQUARESPACE_CACHEVERSION=1522677608633" alt="" /></strong><br />(newspressUSA)<br /><strong style="font-weight: bold;"><span>The Genesis Essentia Concept.</span></strong><span style="font-size: 12px;">&nbsp;</span></span></p>
<p>Other brands were either worth mentioning for the right reasons, or the wrong reasons.&nbsp;<strong>GMC</strong>&nbsp;blew their brand conceit to smithereens with its Sierra AT4. I only have one simple question: Why? And a follow-up: WTF were you guys thinking? Never mind, clearly you weren&rsquo;t. The Sierra AT4 is apropos of nothing to do with the GMC brand.</p>
<p><span class="full-image-block ssNonEditable"><strong><img src="/storage/2019-GMC-Sierra-AT4-025.jpg?__SQUARESPACE_CACHEVERSION=1522677758858" alt="" /></strong><br />(GMC)<br /><strong style="font-weight: bold;"><span>The GMC Sierra AT4.</span></strong><span style="font-size: 12px;">&nbsp;</span></span></p>
<p>And I don&rsquo;t have to ask what&nbsp;<strong>Acura</strong>&nbsp;operatives are thinking anymore, because they have been lost in the Twilight Zone for years. The RDX is abysmal, proof positive that they don&rsquo;t have a clue as to what they&rsquo;re doing. Honda needs to press the reset button for Acura and start over. It&rsquo;s the only hope for the brand.</p>
<p><span class="full-image-block ssNonEditable"><strong><img src="/storage/2018 New York International Auto Show Acura RDX-4.jpg?__SQUARESPACE_CACHEVERSION=1522677780055" alt="" /></strong><br />(newspressUSA)<br /><strong style="font-weight: bold;"><span>Acura RDX.</span></strong></span></p>
<p>And the new&nbsp;<strong>Hyundai Santa Fe</strong>&nbsp;was simply forgettable, which means more of the same from the Korean brand. The&nbsp;<strong>Nissan Altima</strong>&nbsp;seems better overall, but since Nissan deploys some of the consistently worst designs in the business it&rsquo;s more of a sigh of relief than a rousing endorsement. And the <strong>Toyota Corolla Hatchback</strong> is a significant upgrade and nicely done.</p>
<p><span>My final comment today is about&nbsp;<strong>Porsche</strong>. I knew this was coming and it was probably inevitable, but we have reached&nbsp;<strong>Peak Porsche</strong>. This isn&rsquo;t about the fact that it&rsquo;s predominantly a truck brand, because every automaker worth its salt is a truck brand now. There was something missing about Porsche at the New York show, a hollowness that was palpable.&nbsp;</span></p>
<p><span class="full-image-block ssNonEditable"><span><img src="/storage/2018 New York International Auto Show Porsche-3.jpg?__SQUARESPACE_CACHEVERSION=1522677806899" alt="" /><br /><span>(newspressUSA)</span><br /><strong><span>Porsche 911 GT3 RS.</span></strong></span></span></p>
<p>The German manufacturer had on display a yellow 911 T, a lime green 911 GT3 RS, a silver Cayenne and two white Panamera Hybrids (one of them a Sport Turismo). The most alluring Porsche on display? A beautifully restored white 356 Cabriolet from Porsche Classic. What does that tell you? My feeling is that endless variations of the 911 is a product strategy that has been played out. And the modern Porsche models on display felt calculated and oddly uninvolving. The GT3 RS seemed like it had been done 1000 times before, because well, it has, and the 911 T is yet another blatant money grab adhering to the traditional Porsche marketing formula, which goes something like this: De-contenting + Limited Production = Piles of Ca$h. And the Panamera models were coldly antiseptic and off-putting, like they showed up to a party that they weren&rsquo;t invited to.&nbsp;</p>
<p><span>Memo to the brainiacs at Porsche: you have reached a critical juncture in your history, and I'm not even sure the much-touted, all-electric "Mission E" machine will be enough to save you. Porsche has become ubiquitous in the leafy suburbs and urban centers all across the country, but is that a good thing for the long-term health of the brand? I will answer that for you, no, it isn&rsquo;t. We watched as BMW strategists embarked on a strategy of putting a BMW in every neighborhood in America, chasing niches both real and imagined, and the result is that the brand has lost its luster (see Peter&rsquo;s comments about the BMW 440i in &ldquo;<span style="text-decoration: underline;"><a href="http://www.autoextremist.com/on-the-table1/" target="_blank">On The Table</a></span>&rdquo; -WG). And now Porsche seems to be doing the same.&nbsp;</span></p>
<p><span>Porsche operatives need to ask themselves the following: What is Porsche? Why does Porsche exist? Where do we &ndash; as a company &ndash;&nbsp;go from here? And why should we &ndash;&nbsp;as enthusiasts &ndash;&nbsp;care? And remember one very important thing, just having hybrids and BEVs does not mean the brand will survive.</span></p>
<p><span>And that&rsquo;s the High-Octane Truth for this week.</span></p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>

        
  
          
  
         
  
      </div>

    

  </div>

      <div class="journal-entry-tag journal-entry-tag-post-body">
      <div class="journal-entry-tag-post-body-line1"><span class="posted-by">  <a href="/current/author/wordgirl"> <img title="Author" alt="Author" class="inline-icon user-registered-icon" rel="blk_ko_18" src="/universal/images/transparent.png" />Editor</a></span> |  <span class="share-item"><a href="javascript:noop();" onclick="Squarespace.Interaction.shareLink(this,'%2Fcurrent%2F2018%2F4%2F2%2Fthe-good-the-bad-and-the-mostly-ugly-from-the-new-york-auto.html','THE%20GOOD%2C%20THE%20BAD%20AND%20THE%20MOSTLY%20UGLY%20FROM%20THE%20NEW%20YORK%20AUTO%20SHOW.');"> <img title="Share Article" alt="Share Article" class="inline-icon share-icon" rel="blk_ko_18" src="/universal/images/transparent.png" />Share Article </a></span> |  <span class="email-item"><a href="/current/recommend/36052717"> <img title="Email Article" alt="Email Article" class="inline-icon email-icon" rel="blk_ko_18" src="/universal/images/transparent.png" />Email Article </a></span> |  <span class="print-item"><a href="/current/2018/4/2/the-good-the-bad-and-the-mostly-ugly-from-the-new-york-auto.html?printerFriendly=true"> <img title="Print Article" alt="Print Article" class="inline-icon print-icon" rel="blk_ko_18" src="/universal/images/transparent.png" />Print Article </a></span> </div>
      <div class="journal-entry-tag-post-body-line2"></div>
      <div class="journal-entry-tag-post-body-line3"></div>
    </div>
  
  
  <div class="clearer"></div>

</div>
</div>





  </div>

  

  

      
  <div class="journal-entry-navigation">

    
      
      <a class="journal-entry-navigation-main" href="/current/">Main</a>
       | <a class="journal-entry-navigation-next" href="/current/2018/3/26/on-the-eve-of-the-new-york-auto-show-the-detroit-auto-show-f.html">ON THE EVE OF THE NEW YORK AUTO SHOW, THE DETROIT AUTO SHOW FADES TO BLACK. &raquo;</a> 

    

  </div>


  

  

  
  

  


  

  

  
  

</div></div> <!-- Content -->
  
    
  
    </div></div> <!-- Page Body -->

    
    
    <div id="pageFooterWrapper"><div id="pageFooter">
  
              <a href="/current/">RANTS</a>  |  <a href="/on-the-table1/">ON THE TABLE</a>  |  <a href="/fumes1/">FUMES</a>  |  <a href="/the-line1/">THE LINE</a>  |  <a href="/emails-of-the-week1/"> READER MAIL</a>  <br><br>

THE UNAUTHORIZED USE OF ANY EDITORIAL OR PHOTOGRAPHIC CONTENT FROM AUTOEXTREMIST.COM WITHOUT WRITTEN PERMISSION FROM THE PUBLISHER IS STRICTLY PROHIBITED.<br>
<a href="/copyright/">Copyright Statement</a> ~ © 1999-2018 Autoextremist.com, Inc. ~ <a href="/privacy-policy/">Privacy Policy</a>
      
  
      
  
    </div></div>
  
  </div></div> <!-- Canvas -->
  
   


  <div class="clearer" id="bodyClearer"></div>

  



</body>
</html>